二蛋 发布的文章

PHP获取当前页面URL

在PHP众多预定义服务器变量中,$_SERVER["REQUEST_URI"] 算是经常用到的,但是这个变量只有apache才支持,因此,我们需要一个更加通用的方式来获取REQUEST_URI的值,本文就是结束这一问题的解决方案

// 说明:获取 _SERVER['REQUEST_URI'] 值的通用解决方案 
// 整理:www.2dan.cc 
<?php
function request_uri() 
{
    if (isset($_SERVER['REQUEST_URI'])) 
    {
        $uri = $_SERVER['REQUEST_URI']; 
    }
    else
    {
        if (isset($_SERVER['argv'])) 
        {
            $uri = $_SERVER['PHP_SELF'] .'?'. $_SERVER['argv'][0]; 
        }
        else
        {
            $uri = $_SERVER['PHP_SELF'] .'?'. $_SERVER['QUERY_STRING']; 
        }
    }
    return $uri; 
}
?>

align的AbsBottom 、AbsMiddle 、Baseline 、Bottom 、Middle

AbsBottom 图像的下边缘与同一行中最大元素的下边缘对齐。 AbsMiddle 图像的中间与同一行中最大元素的中间对齐。 Baseline 图像的下边缘与第一行文本的下边缘对齐。 Bottom 图像的下边缘与第一行文本的下边缘对齐。 Left 图像沿网页的左边缘对齐,文字在图像右边换行。 Middle 图像的中间与第一行文本的下边缘对齐。 NotSet 未设定对齐方式。 Right 图像沿网页的右边缘对齐,文字在图像左边换行。 TextTop 图像的上边缘与同一行上最高文本的上边缘对齐。 Top 图像的上边缘与同一行上最高元素的上边缘对齐。

Linux上安装KDE, Gnome和VNC

安装所需环境:
需要至少256m的可用内存(128也可以不过有点卡)
CentOS或类似OS(Debian的话改成apt-get应该也可以)

1,安装KDE

yum install kdepim

或安装Gnome(256内存可两个都安装)

yum groupinstall gnome-desktop
yum install gnome-session

2,安装VNC和其他

yum -y install vnc vnc-server firefox x11-xorg
yum -y install fonts-chinese

重要:要执行:

yum groupinstall "X Window System" "GNOME Desktop Environment" "KDE (K Desktop Environment)"

这个,不然不稳定



- 阅读剩余部分 -

IE6 IE7 Firefox Opera Safari 的 CSS Hacks

IE系列

div { +property:value; } 在属性名前加上加号”+”,这个Hack只有IE系列可以识别.
div { *property:value; } 在属性名前加上星号”*”,这个Hack只有IE系列可以识别.
div { _property:value; } 在属性名前加上下划线”_”,这个Hack只有IE6 识别.
background-color:red\0; /* ie 8/9*/
background-color:blue\9\0; /* ie 9*/

IE的if条件Hack

<!--[if !IE]><!--> 除IE外都可识别 <!--<![endif]-->
<!--[if IE]> 所有的IE可识别 <![endif]-->
<!--[if IE 5.0]> 只有IE5.0可以识别 <![endif]-->
<!--[if IE 5]> 仅IE5.0与IE5.5可以识别 <![endif]-->
<!--[if gt IE 5.0]> IE5.0以及IE5.0以上版本都可以识别 <![endif]-->
<!--[if IE 6]> 仅IE6可识别 <![endif]-->
<!--[if lt IE 6]> IE6以及IE6以下版本可识别 <![endif]-->
<!--[if gte IE 6]> IE6以及IE6以上版本可识别 <![endif]-->
<!--[if IE 7]> 仅IE7可识别 <![endif]-->
<!--[if lt IE 7]> IE7以及IE7以下版本可识别 <![endif]-->
<!--[if gte IE 7]> IE7以及IE7以上版本可识别 <![endif]-->

- 阅读剩余部分 -